Home | Software Map | Motif Forums | Bug Home sponsored by ICS 
Bugzilla Bug
  1655
     Query page      Enter new bug
Bug#:1655 Platform: Version:
Product: OS: Reporter:bhelf@flitterfly.whirpon.com (Bill Helfinstine)
Status: RESOLVED Priority: Cc:
Resolution: FIXED Severity: Component:
Assigned To: ochern@ics.com (Oleksiy Chernyavskyy) Target Milestone:
URL:
Summary:
Attachments: 11/15/16 16:28Patch to runtime-patch VendorShell reference
Create a new attachment (proposed patch, testcase, etc.)
Bug 1655 depends on: Show dependency tree
Show dependency graph
Bug 1655 blocks:
Votes for bug 1655:    Vote for this bug

Additional Comments:


Leave as RESOLVED FIXED
Reopen bug
Mark bug as VERIFIED
Mark bug as CLOSED

View Bug Activity Format For Printing
Description: Opened: 2016-11-15 16:25

The XQuartz 2.7.9 release of X11 for MacOS has changed the way that the libXt
shared library is built, removing the -flat_namespace flag from it.

This means that Xt widget libraries like Motif and Athena that override the
VendorShell widget class can no longer do so by just declaring variables and
having the linker do the work, like they can on ELF platforms like linux and
solaris.  

The XQuartz maintainer added some extra code to libXaw that fixes this at
runtime for Athena Widgets.  I've ported that code to Motif, and it does indeed
make Motif applications work again on recent MacOS.


------- Additional Comments From Bill Helfinstine 2016-11-15 16:28 -------
Created an attachment (id=405)
Patch to runtime-patch VendorShell reference


------- Additional Comments From Oleksiy Chernyavskyy 2017-08-30 23:40 -------
Thanks for the patch. I applied it with some changes. The issue is fixed.
PS: XQuartz also ships binary compatible version of libXt that can be used with 
older Motif builds.

     Query page      Enter new bug
This is Mr. Samsa: the Open Motif bug system using Bugzilla. For more information about what Bugzilla is and what it can do, see mozilla.org's bug pages.
New | Query | bug # | Reports | New account | Log in